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Formulas are one of the most useful features in Excel. Formulas can be used to perform basic number 
crunching, such as addition or subtraction, as well as more complex calculations such as payroll deductions 
or averaging a student's test results.  
 

Overview of Formulas 
 
Formulas are equations that perform calculations on numbers or values in a worksheet.   
 
Examples of Formulas and Functions 
 

=2*3+5   Multiplies 2 by 3, then adds 5  
=A1+A2+A3  Adds the values in cells A1, A2, and A3 
=SUM(A1:A5)  Sums the range of values in cells A1, A2, A3, A4 and A5 
=TODAY()  Returns the current date 
=UPPER("hello") Converts the text hello to HELLO using the UPPER 
function 
=IF(A1>0)  Tests the contents of cell A1 to determine if it contains a value greater than 0 

 

Using Basic Arithmetic operators 

For performing basic mathematical operations such as addition, subtraction, or multiplication; combining 
numbers; and producing numeric results, use the following arithmetic operators: 

 

*When A1=8 and A2=2 

Creating Formulas  
 
Formula basics: 
 

1. A formula may be entered either in the cell in which you want the answer of the calculation to 
appear, or alternatively, the cell may be selected and the formula can be entered in the formula bar. 

 

ARITHMETIC OPERATOR MEANING EXAMPLE RESULT 

+ (plus sign) Addition =A1+A2 10 

– (minus sign) Subtraction or Negation =A1-A2 6 

* (asterisk) Multiplication =A1*A2 16 

/ (forward slash) Division =A1/A2 4 

^ (caret) Exponentiation =A1^A2 64 
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For example, to add cells A1 and A2, and have the answer appear in A3, type =A1+A2 in cell A3. The 
formula =A1+A2 appears in the formula bar as you type.  Once the formula is entered, only the result 
appears in the cell.  The actual formula is only visible on the formula bar when the cell is selected.   

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Formulas must always begin with an equals sign (=). The equals sign at 
the beginning of a formula indicates to Excel that you are entering a formula 
rather than a value.  
 

3. Enter the formula immediately following the equal sign with no spaces. For 
example, =A1+A2.   
 

4. Generally, the cell addresses not the values (numbers) should be entered 
and calculated in the formula. This is known as making a cell reference. 
There are times when entering values is necessary, but for basic formulas and functions, enter cell 
addresses. 
 
NOTE: Every Excel worksheet is made up of thousands of rectangles, called cells. Each cell has its 
own name, called a cell address. A cell address is the intersection of the column (letter identifier) 
and a row (number identifier). For example, the cell address of the cell in the A column and the third 
row is A3. 

 
 

Practice Exercise:  Using Arithmetic Operators 

 
1. Open the Excel_Practice_File workbook from the Documents folder 
2. Click on the Formulas & Functions sheet 
3. Click in cell B9: type the formula for Addition , =B4+B5+B6+B7+B8, then press Enter 
4. Click in cell D9: type the formula for Subtraction, =D7-D8, then press Enter 
5. Click in cell F9: type the formula for Multiplication, =F7*F8, then press Enter 
6. Click in cell H9: type the formula for Division, = H7/H8, then press Enter 

Formula Bar 

Cell 

Enter the formula 

in the cell and 

Press enter on the 

keyboard. The 

formula calculates 

and displays the 

The formula 

automatically 

recalculates when 

the value of a 

referenced cell is 

changed. 
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Changing Values with Cell References 
 
An advantage of using cell references in formulas is that they allow you to update data in your worksheet 
without having to rewrite the formula.  
 

 
Edit or Double-Check your Formula 

 

Sometimes it’s necessary to edit or double-check your formula. In the exercise below we will look at an 

existing formula and edit it. 

 

1. In the Excel_Practice_File go to the Formulas & Functions worksheet  

2. Select the cell containing the formula to be edited. In our example, we'll 

click on cell B9 

 

Look above at the formula bar. The formula is now visible in the formula bar.  

 

 

3. Click in the formula bar to edit the formula  

4. Change one of the plus signs in the formula to a minus sign 

5. Press Enter. The formula will recalculate and change the result in the B9 cell 

 

NOTE: An alternate way to edit the formula is to double-click the cell to view and edit the formula directly 

within the cell. 

 

Functions 
 
A function is a predefined formula that performs calculations using specific values in a particular order. One 
of the key benefits of functions is that they can save you time since you do not have to write the formula 
yourself.  
 
Excel has hundreds of different functions to assist with your calculations. 

 
The Structure of a Function 
 

• The order in which you insert a function is 
important. Each function has a specific order, 
called syntax, which must be followed for the 
function to work correctly.  

 

• The basic syntax to create a formula with a 

function is to insert an equal sign (=), a function 
name (SUM, for example, is the function name 
for addition), and an argument. Arguments 
contain the information you want the formula to 
calculate, such as a range of cell references. 

Practice Exercise: Changing Values with Cell References 

 
In the exercise below, the value in a cell will be changed and the formula will automatically update. 
 

1. In the Excel_Practice_File go to the  Formulas & Functions  worksheet 
2. Click the B4 cell and change the value to 40 
3. Press Enter on the keyboard; the formula recalculates in the B9 cell 
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Function Basics:  
 

• Functions always begin with an = sign 

• Functions never contain spaces 

• Functions can be typed in uppercase 

(CAPS) or lowercase letters.   

• An opening and closing parenthesis must 

always be entered around the argument 

(the cells you want to calculate) 

 
 
 
Examples of Basic Functions 
 

 
Using Cell References in Formulas 
 
A reference identifies a cell or a range of cells on a worksheet and tells Excel where to find the values or 
data for the formula. With references, data contained in different parts of a worksheet can be used in one 
formula or the value from one cell can be used in several formulas. Cells can also be referenced on other 
sheets in the same workbook and in other workbooks. References to cells in other workbooks are called 
links or external references. 
 

TO REFER TO: USE: 

The cell in column A, row 10 A10 

The range of cells in column A and rows 10 through 20 A10:A20 

All cells in row 5 5:5 

All cells in rows 5 through 10 5:10 

All cells in column H H:H 

All cells in columns H through J H:J 

The range of cells in columns A through E and rows 10 through 20 A10:E20 

 
The SUM function  
 
SUM is a function in Excel that adds values. The SUM function can 
add individual values, cell references, ranges or a mix of all three. 
Most commonly people use ribbon commands or the function library to 
insert functions, but any function can also be typed into a cell 
manually.  

FUNCTION MEANING EXAMPLE 

=SUM(CELL RANGE) Sums (adds) the value of cells =SUM(A1:A5) 

=AVERAGE(CELL RANGE) Averages the values of cells =AVERAGE(A1:A5) 

=COUNT(CELL RANGE) Counts number of non-blank cells =COUNT(A1:A5) 

=MIN(CELL RANGE) Finds the minimum value in a range of cells =MIN(A1:A5) 

=MAX(CELL RANGE) Finds the maximum  value in a range of cells =MAX(A1:A5) 
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Reference operators 
 
To combine ranges of cells for calculations use the following operators: 
  

REFERENCE OPERATOR MEANING EXAMPLE 

: (colon) Range operator, which produces one reference to all of the 
cells between two references, including the two references 

B5:B15 

, (comma) Union operator, which combines multiple references into 
one reference  

SUM(B5:B15,D5:D15) 

 

Using the Comma Reference Operator 
 
In the exercise above the function contained one argument (D3:D37). In this next activity, the comma 
reference operator will be used to add multiple, separate arguments. Each argument must be separated by 
a comma. For example, the function =SUM(A1:A10, C1, E2) will add the values in all of the referenced cells. 

In the Excel_Practice_File, go to the utilities worksheet   
 

1. Click in cell E8 to make it the active cell 

2. Go to the Home tab → Editing group → click the AutoSum command  

3. Click and drag the cursor over the E3:E7 cell range 

4. Press the , key on the keyboard 

5. Click on the F3 cell.  

6. Look at the E8 cell. The function in the cell should now be 
=SUM(E3:E7,F3) 

7. Hit Enter to see the answer ($423.38) 
 
Using the comma reference operator in the exercise above allowed for a cell range, E3:E7 to be added with 
cell E3. 
 
Autosum 
 
The AutoSum command is a shortcut to using Excel's SUM function and several 
other functions like AVERAGE, MIN, MAX etc. The SUM function provides a quick 

Practice Exercise: The Structure of a Function 
 
In the Excel_Practice_File, go to the utilities worksheet   
 

1. Click in cell D8 to make it the active cell 

2. Go to the Home tab → Editing group → Click the AutoSum command  

 
Now, look back at the D8 cell. The SUM function has been inserted in this cell. Let’s look at the different parts 
of the function. 

 

• The function starts with = (always!) 

• SUM: is the name of the function we are using 

• The range of values being used are inside the parenthesis 

• The : (colon) symbol is being used to indicate all of the cells between 

the two cells listed in the function. In this example the cells between 

D3 and D7 will be included in the function 

• Excel also highlights the cells included in the function 

 
3. Press Enter to finish the function and see the answer 
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way to add columns or rows of numbers in a spreadsheet. Excel inserts the built-in SUM function into the 
active cell and simultaneously selects what the program thinks is the most likely range of numbers that you 
want added together. 
 
NOTE: Excel first looks above the selected cell for a group of numbers to add; if none are found, it looks to 
the left of the selected cell. 
 
The AutoSum command icon is the Greek letter Sigma, which looks like an E or sideways M   
 
1. In the Excel_Practice_File, go to the numbers worksheet  

2. Click on the A11 cell to make it the active cell  

3. Go to the Home tab → Editing group → 

AutoSum command  

4. Excel places “marching ants” around the numbers it assumes 

should be included in the function. If it’s correct, press Enter on 

the keyboard and Excel automatically totals the selected 

numbers. 

 
NOTE: If the marching ants are not around the correct cells, click 
and drag over the correct cells and hit Enter on the keyboard. To 
cancel the marching ants, hit the Esc key. 
 
Copying Formulas using the Fill Handle 
 
A quick way of copying formulas in Excel is to use the Fill Handle.  In addition to copying formulas and data, 
the fill handle will also copy formatting.  
 

1. Click on cell A11 in the numbers worksheet to make it the active cell 

2. Place the mouse pointer over the black square in the bottom right corner of the 

cell. The pointer will change to a dark plus sign " + " 
3. Click and hold the left mouse button and drag the fill handle across to cell G11 

4. Release the mouse button. The SUM function was copied and placed in the 

B11:G11 cells 

 
 
NOTE: When you release the fill handle the Auto Fill Options drop down 
menu should also appear below cell G11. Click on the down arrow in the 
menu to open it. The formula copied because the copy cells option is 
selected. 
 
 
 
 
 

Practice Exercise: Copying Formulas using the Fill Handle 
 

1. Select the utilities worksheet; click to make it the active sheet 

2. Click the G3 cell to make it the active cell to calculate the totals for each utility 

3. Click the AutoSum button and hit the Enter key 

4. Click back to the G3 cell to make it the active cell 

5. Place the mouse pointer over the Fill Handle in the bottom right corner of the G3 cell. The pointer 

will change to a plus sign “+ " 

6. Click the left mouse button and drag the fill handle down to cell G7 

7. Release the mouse button. Cells G3 to G7 contain the results for each Utility 
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Simple Calculations from the Home Tab 
 
Functions are also available for other simple calculations. The AutoSum command builds formulas that 
compute the average value, count the number of values, or return the highest or lowest value in a range. 
Click the drop-down button that's attached to the AutoSum command on the Home tab and then click 
Average, Count Numbers, Max, or Min from the  drop-down menu. 
 

Practice Exercise: Using Functions 

 
1. In the Excel_Practice_File, go to the Formulas and Functions worksheet 

2. Enter the functions in the highlighted cells for each column 

• Cell B17 type the function for Sum, =Sum(B12:B16) 

• Cell D17 type the function for Average, =Average(D12:D16) 

• Cell F17 type the function for Count, =Count(F12:F16) 

• Cell H17 type the function for Maximum, =Max(H12:H16) 

• Cell J17 type the function for Minimum,  =Min(J12:J16) 
 

 
 
Correcting Cell Selection Errors 
 
Excel functions from the AutoSum command automatically select the cell range to calculate. The way the 
Excel program selects cells is by first looking above the selected cell for values; if none are found, it looks to 
the left of the selected cell. In this next exercise we will pay attention to the cell ranges that Excel selects and 
correct errors. 
 

Practice Exercise:  AutoSum, Auto AVERAGE, Auto MAX and Auto MIN 

1. In the Excel Excel_Practice_File go to the romances worksheet and select cell B11  

2. Go to Home tab → Editing group → AutoSum command to insert the AutoSum function  

3. Check that Excel has selected the correct cell range to include in the AutoSum function (B4:B10)  

4. If the cell range is correct, press Enter  

5. Select cell B12 and go to Home tab → Editing group → AutoSum command arrow to insert the Auto 
AVERAGE formula to average cells B4 to B10 

6. Look in cell B12 to check that the Auto AVERAGE function is selecting cells B4:B10.  

In this case Excel is selecting cells B4:B11 which is not correct because the total amount in B11 should 
not be included in the average calculation. To correct the problem click and drag the mouse from cell 
B4 to B10. Notice that the cell range changes in the function. Press Enter to finalize the function 

7. Click the B13 cell to make it the active cell, insert the Auto MIN  function to find the minimum value in 
cells B4 to B10  

8. Look in cell B13 to check that the correct cell range is selected. If not, correct the problem by clicking 
and dragging over the correct cell range 

9. Press Enter to finalize the function and see the answer 
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Auto Calculate 
 
Excel offers some of the most common 
computations in the status bar at the bottom of 
the screen.  
 
Click and drag over the cells containing the values to be Auto Calculated and look at the right half of the 
status bar at the bottom of the Excel window.  
 
The calculated Average, Count, and Sum for the selection should be 
displayed. 
 
On the romances worksheet, select cells B4 through E10.  
 
To choose the functions displayed in the status bar, right-click the status 
bar and select and/or deselect functions from the Customize Status Bar 
shortcut menu. 

 
Show Formulas 
 
The Show formulas button allows you to quickly show all the formulas in your 
Excel Spreadsheet instead of the result. Doing so does not change your 
spreadsheet, just the way it is displayed. The Show formulas command allows 
you to quickly and easily check your spreadsheet for errors in your formulas. 
 

 
 
Insert Function Dialog Box  
 
So far in this class we have learned how to insert 
some basic functions using the AutoSum 
command. There are hundreds of functions in 
Excel, but there is no need to learn every single 
function in the program. All of Excel’s functions 
are available through the program’s Function 
Library. In this next section we will use the Function Library to insert functions.  
 
To insert a function, go to the Formulas tab → Function Library group → Insert Function command or 

click the fx command on the formula bar. 

10. Click the B14 cell to make it the active cell, insert the Auto MAX  function to find the minimum value in 
cells B4 to B10 

11. Look in cell B14 to check that the correct cell range is selected. If not, correct the problem by clicking and 
dragging over the correct cell range  

12. Press Enter to finalize the function and see the answer 

Practice Exercise: Show Formulas 

 
1. Go to the Romances worksheet  

 
2. Go to the Formulas tab → Formula Auditing group → Show Formulas to see the actual formula 

displayed in cell F3 
 
To Turn off the Show Formulas and display the results,  Go to the Formulas tab → Formula Auditing group 
→ Show Formulas   
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Function categories include: 
 

• Add-in and Automation 

• Cube  

• Database  

• Date and time  

• Engineering  

• Financial  

• Information   

• Logical  

• Lookup and reference  

• Math and trigonometry  

• Statistical  

• Text  

 
  
In the next exercise we will insert a date function. In the sales world it is not beneficial to keep inventory for 
too long. A salesman might insert the TODAY function to keep track of the current date, but can also 
include the function in a separate formula to quickly determine how long a vehicle has been part of the 
dealership’s inventory. 
 
TODAY Function  
 
The TODAY() function is a non-mathematical date function that takes no argument and returns today’s date. 
If you use this function in an Excel worksheet, today’s date will appear each time you reopen the file.  
 
First, let’s make space for the function:  
 
1. In the Excel_Practice_File, go to the PivotTable 

worksheet  
2. Click on the row heading for row 1 
3. Go to Home tab → Cells group → Click the Insert 

command three times 
4. Click on cell A1 and type the words Today’s Date: 
5. Press Tab to move the cursor to cell B1 
 
Now, we will insert the TODAY function: 
 
1. Make sure that your cursor is in the B1 cell. If not, click 

on cell B1 - this is the cell where the function will be 
placed 

2. Go to Formulas tab → Function Library group → 
Insert Function command 

3. Click in the Search for a function text box and type 
today   

4. Click Go; the TODAY function is now highlighted in the 
select a function box 

5. Click OK in the Insert Function dialog box 
6. The Function Arguments dialog box appears; click OK to continue 
 
 
Today’s date appears in cell A2 
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Comparison operators 
 
When two values are compared using these operators, the result is a logical value: either TRUE or FALSE. 
Compare two values using the following operators: 

 

COMPARISON OPERATOR MEANING  EXAMPLE 

= (equals sign) Equal to  A1=B1 

> (greater than sign) Greater than  A1>B1 

< (less than sign) Less than  A1<B1 

>= (greater than or equal to sign) Greater than or equal to  A1>=B1 

<= (less than or equal to sign) Less than or equal to  A1<=B1 

<> (not equals to sign) Not equal to A1<>B1 

 
IF Function 
 
The IF function tests a user-defined condition and returns one result if the condition is true, and another 
result if the condition is false. This is where Excel starts to “think” and make decisions based on criteria 
entered in the spreadsheet. 
  
There are three distinct parts to any IF statement: 
 

1. logic test  
2. value if true  
3. value if false  

 
Syntax:  =IF(logical test, value if true, value if false)  
 
All three parts of the IF statement must always appear in the formula, and always in the correct order.  
Example 
 
The math teacher has decided that students who scored an 88% average on the first four tests are exempt 
from having to take the final. Use the IF formula to determine who will and will not have to take the final. The 
question being asked is: Does this student need to take the final?  
 

1. In the Excel_Practice_File, go to the math scores sheet 
 
2. Calculate the average for each student’s scores by inserting the AVERAGE function in cell F3 

 
3. Use the autofill tool to copy the AVERAGE function to cells F4:F52 

 
4. Click in the G3 cell to make it the active cell 
5. Go to the Formulas tab → Function Library group → Insert Function command  

 
6. In the Insert Function dialog box, select the IF function 

 
7. Click OK in the Insert Function dialog box 

 
8. The Function Arguments dialog box opens and displays three parts of the IF statement that must 

be entered to create the function. 
 

9. In the Logical_test box, type F3>=88 
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10. If students score an 88 or 

higher, they do not have to 
take the test, so enter No 
Test Needed next to 
Value_if_true  
 

11. Enter Test Needed next to 
Value_if_false 
 

12. Click OK  
 
 
 

 
 

Practice Exercise – IF Function 

 
Complete the rest of the IF statements for the other students. This can be done most simply by copying the 
existing IF function in the G4 cell using the Autofill Handle. 


