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Using charts and graphs in Excel is an excellent way to communicate the meaning of a group or series of 
numbers in a simple, visual way that makes more sense to most people than looking at raw data. 
 
Charts and graphs can be used to see how much your gas bill has changed over a 12 month period, which 
salespeople are bringing in the most money, which flavor of popsicle is most popular, and other numerical 
comparisons. Any range of data input in Excel can be translated into a chart or graph, which can especially 
useful when giving presentations in work situations. The concept behind charts and graphs is that a picture is 
worth a thousand words; today we will learn how to draw those pictures with Excel. 
 
 

Common Types of Charts 
 
Excel offers a variety of charts and most have several subtypes associated with them. Be sure to choose the 
correct chart for the data in the spreadsheet. 
 

• Column 

• Line 

• Pie 

• Area 

• Bar 
 

 

 

 

 

 

 

 

 

 

Column Chart 
 
Column Charts compare different object levels over time using a 
vertical format. Data that is arranged in columns or rows on a 
worksheet can be plotted in a column chart. Column charts are useful 
for showing data changes over a period of time or for illustrating 
comparisons among items. Categories are typically organized along 
the horizontal axis and values along the vertical axis. 
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Line Chart 
 
Line Charts compares a trend over even time intervals. Data 
that's arranged in columns or rows on a worksheet can be 
plotted in a line chart. Line charts are ideal for showing trends 
in data at equal intervals, like months, quarters, or fiscal years. 
 
 

 
Pie Chart 
 

Pie Charts compare sizes of pieces as part of a whole. Since 
pie charts represent a percentage of a whole, only one row or 
one column of a worksheet can be used.  
 
 

 

 

Area Chart 
 

Area Charts show individual volume changes over time in 
relation to total volume or the size of total change over a period 
of time. For example, data that represents profit over time can 
be plotted in an area chart to emphasize the total profit. 
 

 
 
 
 

 
Bar Chart 
 
Bar Charts compare different object levels over time using a 
horizontal format that arranges data in columns or rows on a 
worksheet. Bar charts illustrate comparisons among 
individual items. 
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Opening an Excel Document 
 

1. Open Excel from the Start menu 
 

2. Open the file excel_practice_file.xls located in the Documents folder on the computer 
 
3. If necessary, click the yellow Enable Editing button at the top of the Excel 

window 
 
Navigate to the worksheet named romances, which lists the date for the number of romance books 
circulated by each branch of the Heights Library System for a one-week period. The days as well as the 
branches can be compared using different charts. The data on this sheet is used to create the charts in the 
following sections. 
 

 
Column Charts 

 
1. Select columns A, B, C, D and E in rows, 3, 4 

and 5  

2. Go to the Insert tab → Charts group → 

Column command 

 
 
 
 
 
 

 
3. Choose the first option under the heading 2-D Column  

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The chart appears on the same sheet on which the data is located. Often, it appears on top of some of the 
data. To move the chart: 
 

1. Click the edge of the window 
 

2. When the 4-headed arrow appears, hold down the left mouse button and drag the chart 
to the desired location. 
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Chart Tools Tabs 
 
When a chart is inserted and selected, three contextual sub tabs appear on the 
right end of the Ribbon:  
 

1. Chart Tools - Design 
2. Chart Tools - Format 

 
NOTE:  The Chart Tools contextual tabs only appear when the chart is selected. 
 
 
Chart Tools Design Sub Tab 
 
The Design sub tab provides tools for changing the look and feel of the chart. To avoid a lot of manual 
formatting, Microsoft Office Excel provides a variety of useful predefined quick layouts and styles. 

 
 
The Chart Styles group can be used to quickly change the general appearance and color of a chart. 
 
To change the chart style:  
 

1. Click the chart to be formatted 
 

2. Go to the Chart Tools Design tab → Chart Styles group → Chart Styles more arrow to open the 
Chart Styles gallery 
 

3. Click  the desired style, such as green style 6  

 
To change the chart color: 
 

1. Click the chart to be formatted  
 

2. Go to the Chart Tools Design tab → Chart Styles group → Change Colors 
command to open the change colors drop down menu 
 

3. Click  the desired chart color, such as color 4  
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The Chart Layouts group provides options for changing the layout of the chart.  
 

1. Go to the Chart Tools Design tab → Chart Layouts group → Quick 

Layout command to see all available layouts 

2. Click the desired layout, such as layout 3  

 
Adding a Title 
 
A title can be added to the chart through the Design sub tab → Charts Layout group → Add Chart 
Element command → Chart Title.  Choose a location for the title, select the words Chart Title, and type in a 
new title. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Adding Data Labels 
 

1. Click the chart to be formatted  

2. Go to the Design sub tab → 

Charts Layout group → Add 

Chart Element command → Data 

Labels 

3. Select Data Callout to place a tag 

with the data label on the chart or 

choose another location where the 

data labels should appear, such 

as Inside End 

 
 
Adding an Axis Title 
 

Axis titles can be added for either or both of the primary axes through the Design sub tab → Charts Layout 

group → Add Chart Element command → Axis Titles; several title options appear.  

 
Adding Gridline and Axes 
 

In the Design sub tab → Charts Layout group → Add Chart Element → gridlines command are options  

to edit the axes and gridlines (for example, adding more horizontal or vertical lines to show additional detail 
on the chart).  
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Switching the Row and Column 
 
To the left of the Chart Layouts group are the Data and Type groups. Using the Data 
group, it is possible to switch rows and columns or choose different data. Switching rows 
and columns can be useful in comparing the data in a different way. 
 

1. If necessary, click the chart to be formatted  
 

2. Go to the Design sub tab → Data group → 
Switch Row/column command 

 
 

NOTE: Some charts do not display correctly 
with the columns and rows swapped. 

 
 
 
 
 
 
 
Moving the Chart to another Worksheet 
 
Excel 2013 offers two ways for a chart to be moved to worksheet: 
 

1. If necessary, click the chart to be moved  
2. Go to the Design sub tab → Location group → Move Chart command 

• To move the chart to a new blank sheet, choose the New sheet bullet and click OK  

• To move the chart to a worksheet that already exists, choose the Object in bullet, 
click the down arrow at the right end of the box and select the desired worksheet 

 
 

 

 

Chart Tools Format Sub Tab 

 
The Format tab contains commands for changing the fill, outline and shape of the plot area, in addition to the 
color, style, outline, and fill of text within the chart. These same commands are located in the Formatting 
Task Pane. 
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Formatting Task Pane 
 
The Formatting Task Pane, which when open, appears on the right side of the excel screen, is a new feature 
in Excel 2019. It contains commands for changing the fill, outline, effect, shape and size of chart elements. In 
addition to the color, style, outline, and fill of the text within the chart. In previous versions of Excel formatting 
changes were made in the format dialog box.  
 
There are two ways to open the Formatting Task Pane: 
 

• Double click on the chart element to edit 

• Format sub tab → Current Selection group → Format Selection 

 
The Chart Options drop down menu is helpful in selecting specific parts of 
the chart to edit. It keeps track of what is currently selected and offers a 
myriad of formatting options such as fills, border and line color, border and 
line style, shadowing, and 3-D formatting. 
 
 
Formatting a Selection 
 
1. Click the chart and open the Formatting Task Pane 
2. Click the down arrow in the Chart Options box  
3. Select the desired section, such as Plot Area 
4. In the formatting task pane click on Fill 
5. Choose the Gradient fill bullet 
6. Click the Preset gradients arrow and choose a gradient color 
 
 
 
 
 
 
In the Formatting Task Pane, Chart Options contains commands to change the fill, outline, effect, shape 
and size of individual chart elements.  
 
Text Options contains commands to alter the color, style, outline, and fill of the text within the chart.  
 
Click the X in the upper right corner to close the task pane 
 
NOTE: Not all formatting options are available for all parts of a chart—the task pane changes to reflect 
options that are available for the current selection. 

 
Line Charts 
 
Let’s compare circulation at Coventry and Main 
using a line chart.  
 
1. If necessary, go to the romances worksheet 

 
2. Select column A and B rows 3 through 10 

 
3. To select a noncontiguous column, hold down 

the Ctrl key on the keyboard and select column 
D, rows 3 through 10  
 

4. Go to the Insert tab → Charts group → Line 
command 
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5. Choose the first option in the second row of the drop-down menu, Line with Markers 
 
 

A line chart with markers appears.  
 

 
 
 

 
 
 
 
 
 
 
 
 
 
 

 
Changing Chart Colors  
 
Charts can be customized by changing the colors of one or more elements.   
 
NOTE:  Changing a color on the chart is automatically reflected in the chart 
key.  
 
1. Double-click the Main line on the chart; the formatting task pane appears 

2. Go to Fill &Line (paint bucket) → Marker → Marker Options 

3. Choose the Built-in bullet 

4. Click the Type arrow and choose a new bullet type 

5. Click the Fill → Color arrow and change the bullet to green 

6. Click the X in the upper right corner to close the task pane  

 
NOTE: In a line chart, fill colors must be chosen for the marker and the line separately.  
 
 

Pie Charts 
 
A pie chart is used to compare the input of various entities to 
a total. For example: comparing the percentages of branch 
contributions to the total circulation on a particular day. 
 

1. If necessary, go to the romances worksheet 
 

2. Select the Saturday data including the labels for row 
10 (columns A through E) 

 
3. Hold down the Ctrl key and select the labels in row 3  

(columns A through E) 
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4. Go to the Insert tab →  
Charts group → Pie  
command  
 
 
 

 
5. Choose the first option under 2-D Pie; a pie chart appears 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Adding Percentages to a Pie Chart 
 
Pie charts can be labeled with percentages so that it’s clear how much of the pie each part occupies.   
 
1. If necessary, click on the chart to select it 

 
2. Go to the Design sub tab → Charts Layout group → Add 

Chart Element command → Data Labels 

3. Choose More Data Label Options from the drop-down list; the 

Formatting Task Pane appears on the right side of the screen 

4. In the Formatting Task Pane, click the checkbox next to 
Percentage  
 

5. Click to remove the checkmarks from the boxes next to any 
other options (usually Value is the default) 

 
7. Click the X in the upper right corner to close the task pane  

 

 
The One-Click Chart 
 
To create a chart with just one click, select the data to be included in the chart and hit the F11 key on the 
keyboard; the chart should appear as a new sheet in the workbook. Try it using the romances sheet: 
 

1. Select rows 3 through 10, columns A through E 
 

2. Press the F11 key on the keyboard; the chart is created on a new page labeled Chart1 
 
NOTE: If a Chart1 sheet already exists, the new chart is named by the next available number. 
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Change Chart Type 
 
Excel makes it easy to change the chart type 
 

1. If necessary, click on the chart to select it  
2. Go to the Design sub tab → Type group → Change Chart Type 

command  
3. The Change Chart Type dialog box appears; select a new chart type 
4. Click Close 

 
 

Tweaking a Chart  
 
Sometimes a chart needs to be tweaked to get the desired look. Following is a common problem that arises: 
 

1. Go to the genre circ worksheet  
 

2. Select cells A2 to C10 
 

3. Go to the Insert tab → Column Chart 
 

4. Choose the first chart 
 
The chart is treating the column containing the years as part of the 
data to be plotted rather than as labels for the horizontal axis. 

 
 
To remedy this issue: 
 

1. Go to the Chart Tools Design sub tab → Data group → Select Data 
command  
 

2. In the Select Data Source dialog box, click on the series name Year in 
the box on the left   
 

3. Click the Remove button in the Legend Entries section 
 

4. In the Horizontal (Category) Axis Labels box on the right, click the Edit button 
 

5. When the Axis Labels dialog box appears, select cells A3 to A10 on the spreadsheet 
 

6. Click OK in the Axis Labels dialog box  
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7. The Select Data Source dialog box should now look like this: 

 
 

8. Click OK to see the corrected chart; the Year 
column is gone and each year is now listed as a 
label along the horizontal axis 
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Practice Exercises 

 
Additional practice! Try making a chart on your own. 
 

1. Add a new sheet to the workbook 
 

2. The data to the right tracks how many popsicles 
were sold over the summer months.  
 
Type the data from the table to the right on your 
spreadsheet.  

  June July August 

Grape 229 380 269 

Cherry 380 430 501 

Banana 120 487 643 

Orange 256 400 520 

    

 
3. Create a chart that shows the changes in popularity of popsicle flavors over the 3-month 

period.  

NOTE: Line charts are useful for showing change over time.  
 

 
4. Create a chart that shows which flavor sold the most overall in the 3-month period. 

NOTE: Stacked bar charts are useful for showing the relationship of individual items to the 
whole. 
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5. Create a chart that shows the percentages of different flavors sold during the month of June.  

NOTE: Pie charts are useful for comparing percentages of a whole. 
 

 

 
6. Add data labels to one or more your charts.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 
7. Change the style and/or colors on one or more of the charts. 
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